const regex = /(?<!Test1\s)Test2(?!\sTest3)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!Test1\\s)Test2(?!\\sTest3)', 'gm')
const str = `1. Test1 Test2 Test3
2. Test1 Test2 NotTest3
3. Test1Not Test2 Test3
4. Test2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}