import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!Test1\\s)Test2(?!\\sTest3)";
final String string = "1. Test1 Test2 Test3\n\n"
+ "2. Test1 Test2 NotTest3\n\n"
+ "3. Test1Not Test2 Test3\n\n"
+ "4. Test2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}