using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!Test1\s)Test2(?!\sTest3)";
string input = @"1. Test1 Test2 Test3
2. Test1 Test2 NotTest3
3. Test1Not Test2 Test3
4. Test2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}