const regex = /^(?!_(?!_))(?!(?:.*[^_\n])?_$)[\w.-]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!_(?!_))(?!(?:.*[^_\\n])?_$)[\\w.-]+$', 'gm')
const str = `Valid Entries:
abc
ABC
Abc123
123a
Abc_12
Abc_12_3a
abc_23_43_fg
___should_work_but_doesnt__________
___ok__
___ok____
__a__
Invalid Entries:
_abc
abc_
_abc_`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}