use strict;
my $str = 'Valid Entries:
abc
ABC
Abc123
123a
Abc_12
Abc_12_3a
abc_23_43_fg
___should_work_but_doesnt__________
___ok__
___ok____
__a__
Invalid Entries:
_abc
abc_
_abc_';
my $regex = qr/^(?!_(?!_))(?!(?:.*[^_\n])?_$)[\w.-]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}