re = /^(?!_(?!_))(?!(?:.*[^_\n])?_$)[\w.-]+$/m
str = 'Valid Entries:
abc
ABC
Abc123
123a
Abc_12
Abc_12_3a
abc_23_43_fg
___should_work_but_doesnt__________
___ok__
___ok____
__a__
Invalid Entries:
_abc
abc_
_abc_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end