#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^http:\/\/mywebsite\/(index\.aspx\?db=[A-Z]+)?#((id%\w+(%3B)?)|(view%\w+(%3B)?)|(page%\w+(%3B)?))*$"
Local $sString = "http://mywebsite/index.aspx?db=DAYTON#id%3D7304%3Bpage%3D1%3Bview%3Dpages" & @CRLF & _
"" & @CRLF & _
"http://mywebsite/#id%3D3D7304%3Bpage%3D1%3Bview%3Dpages" & @CRLF & _
"" & @CRLF & _
"http://mywebsite/#view%3D3D7304%3Bpage%3D1%3Bid%3Dpage" & @CRLF & _
"" & @CRLF & _
"http://mywebsite/#page%3D3D7304%3Bid%3D1%3Bview%3Dpage"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")