package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^http:\/\/mywebsite\/(index\.aspx\?db=[A-Z]+)?#((id%\w+(%3B)?)|(view%\w+(%3B)?)|(page%\w+(%3B)?))*$`)
var str = `http://mywebsite/index.aspx?db=DAYTON#id%3D7304%3Bpage%3D1%3Bview%3Dpages
http://mywebsite/#id%3D3D7304%3Bpage%3D1%3Bview%3Dpages
http://mywebsite/#view%3D3D7304%3Bpage%3D1%3Bid%3Dpage
http://mywebsite/#page%3D3D7304%3Bid%3D1%3Bview%3Dpage`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}