$re = '/^http:\/\/mywebsite\/(index\.aspx\?db=[A-Z]+)?#((id%\w+(%3B)?)|(view%\w+(%3B)?)|(page%\w+(%3B)?))*$/m';
$str = 'http://mywebsite/index.aspx?db=DAYTON#id%3D7304%3Bpage%3D1%3Bview%3Dpages
http://mywebsite/#id%3D3D7304%3Bpage%3D1%3Bview%3Dpages
http://mywebsite/#view%3D3D7304%3Bpage%3D1%3Bid%3Dpage
http://mywebsite/#page%3D3D7304%3Bid%3D1%3Bview%3Dpage';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);