import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http:\\/\\/mywebsite\\/(index\\.aspx\\?db=[A-Z]+)?#((id%\\w+(%3B)?)|(view%\\w+(%3B)?)|(page%\\w+(%3B)?))*$";
final String string = "http://mywebsite/index.aspx?db=DAYTON#id%3D7304%3Bpage%3D1%3Bview%3Dpages\n\n"
+ "http://mywebsite/#id%3D3D7304%3Bpage%3D1%3Bview%3Dpages\n\n"
+ "http://mywebsite/#view%3D3D7304%3Bpage%3D1%3Bid%3Dpage\n\n"
+ "http://mywebsite/#page%3D3D7304%3Bid%3D1%3Bview%3Dpage";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}