#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{0,4}$|^\d{4}-0?$|^\d{4}-(?:0?[1-9]|1[012])(?:-(?:0?[1-9]?|[12]\d|3[01])?)?$"
Local $sString = "" & @CRLF & _
"2" & @CRLF & _
"20" & @CRLF & _
"201" & @CRLF & _
"2016" & @CRLF & _
"2016-" & @CRLF & _
"2016-0" & @CRLF & _
"2016-03" & @CRLF & _
"2016-03-" & @CRLF & _
"2016-03-1" & @CRLF & _
"2016-03-16"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")