import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{0,4}$|^\\d{4}-0?$|^\\d{4}-(?:0?[1-9]|1[012])(?:-(?:0?[1-9]?|[12]\\d|3[01])?)?$";
final String string = "\n"
+ "2\n"
+ "20\n"
+ "201\n"
+ "2016\n"
+ "2016-\n"
+ "2016-0\n"
+ "2016-03\n"
+ "2016-03-\n"
+ "2016-03-1\n"
+ "2016-03-16";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}