const regex = /^\d{0,4}$|^\d{4}-0?$|^\d{4}-(?:0?[1-9]|1[012])(?:-(?:0?[1-9]?|[12]\d|3[01])?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{0,4}$|^\\d{4}-0?$|^\\d{4}-(?:0?[1-9]|1[012])(?:-(?:0?[1-9]?|[12]\\d|3[01])?)?$', 'gm')
const str = `
2
20
201
2016
2016-
2016-0
2016-03
2016-03-
2016-03-1
2016-03-16`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}