package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{0,4}$|^\d{4}-0?$|^\d{4}-(?:0?[1-9]|1[012])(?:-(?:0?[1-9]?|[12]\d|3[01])?)?$`)
var str = `
2
20
201
2016
2016-
2016-0
2016-03
2016-03-
2016-03-1
2016-03-16`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}