use strict;
my $str = '1
12
123
1234
12345
123456
Hello, world.
Hello, world
Hello, world.
^ Spaces added ^';
my $regex = qr/([^\nw].{5}|.[^\no].{4}|.{2}[^\nr].{3}|.{3}[^\nl].{2}|.{4}[^\nd].|.{5}[^\n.]$|^.{0,5})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}