import re
regex = re.compile(r"([^\nw].{5}|.[^\no].{4}|.{2}[^\nr].{3}|.{3}[^\nl].{2}|.{4}[^\nd].|.{5}[^\n.]$|^.{0,5})$", flags=re.MULTILINE)
test_str = ("1\n"
"12\n"
"123\n"
"1234\n"
"12345\n"
"123456\n"
"Hello, world.\n"
"Hello, world\n"
"Hello, world. \n"
" ^ Spaces added ^")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")