re = /([^\nw].{5}|.[^\no].{4}|.{2}[^\nr].{3}|.{3}[^\nl].{2}|.{4}[^\nd].|.{5}[^\n.]$|^.{0,5})$/m
str = '1
12
123
1234
12345
123456
Hello, world.
Hello, world
Hello, world.
^ Spaces added ^'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end