#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((((0[1-9]|[12]\d|3[01])\/(0[13578]|10|12))|((0[1-9]|[12]\d|30)\/(0[469]|11))|((0[1-9]|1[0-9]|2[0-8]))\/02)\/(19\d\d|(200\d|201[0-5])))|(29\/02\/((?!1900)19([02468][048]|[13579][26])|(2000)|(2004)|(2008)|2012))"
Local $sString = "29/02/2004"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")