const regex = /((((0[1-9]|[12]\d|3[01])\/(0[13578]|10|12))|((0[1-9]|[12]\d|30)\/(0[469]|11))|((0[1-9]|1[0-9]|2[0-8]))\/02)\/(19\d\d|(200\d|201[0-5])))|(29\/02\/((?!1900)19([02468][048]|[13579][26])|(2000)|(2004)|(2008)|2012))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((((0[1-9]|[12]\\d|3[01])\\\/(0[13578]|10|12))|((0[1-9]|[12]\\d|30)\\\/(0[469]|11))|((0[1-9]|1[0-9]|2[0-8]))\\\/02)\\\/(19\\d\\d|(200\\d|201[0-5])))|(29\\\/02\\\/((?!1900)19([02468][048]|[13579][26])|(2000)|(2004)|(2008)|2012))', 'g')
const str = `29/02/2004`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}