import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((((0[1-9]|[12]\\d|3[01])\\/(0[13578]|10|12))|((0[1-9]|[12]\\d|30)\\/(0[469]|11))|((0[1-9]|1[0-9]|2[0-8]))\\/02)\\/(19\\d\\d|(200\\d|201[0-5])))|(29\\/02\\/((?!1900)19([02468][048]|[13579][26])|(2000)|(2004)|(2008)|2012))";
final String string = "29/02/2004";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}