use strict;
my $str = '29/02/2004';
my $regex = qr/((((0[1-9]|[12]\d|3[01])\/(0[13578]|10|12))|((0[1-9]|[12]\d|30)\/(0[469]|11))|((0[1-9]|1[0-9]|2[0-8]))\/02)\/(19\d\d|(200\d|201[0-5])))|(29\/02\/((?!1900)19([02468][048]|[13579][26])|(2000)|(2004)|(2008)|2012))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}