using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((((0[1-9]|[12]\d|3[01])\/(0[13578]|10|12))|((0[1-9]|[12]\d|30)\/(0[469]|11))|((0[1-9]|1[0-9]|2[0-8]))\/02)\/(19\d\d|(200\d|201[0-5])))|(29\/02\/((?!1900)19([02468][048]|[13579][26])|(2000)|(2004)|(2008)|2012))";
string input = @"29/02/2004";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}