#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w.]+@[a-zA-Z]+[.]{1}com$"
Local $sString = "dsfdsf@gmail.com" & @CRLF & _
"sdsf@gg" & @CRLF & _
"sdfsdf_sdfsdf@gmail.com" & @CRLF & _
"sdfdsf.sdfds@gg.com" & @CRLF & _
"sdfsdf/sdfdsf/@gmail.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")