$re = '/^[\w.]+@[a-zA-Z]+[.]{1}com$/m';
$str = 'dsfdsf@gmail.com
sdsf@gg
sdfsdf_sdfsdf@gmail.com
sdfdsf.sdfds@gg.com
sdfsdf/sdfdsf/@gmail.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);