const regex = /^[\w.]+@[a-zA-Z]+[.]{1}com$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\w.]+@[a-zA-Z]+[.]{1}com$', 'gm')
const str = `dsfdsf@gmail.com
sdsf@gg
sdfsdf_sdfsdf@gmail.com
sdfdsf.sdfds@gg.com
sdfsdf/sdfdsf/@gmail.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}