using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w.]+@[a-zA-Z]+[.]{1}com$";
string input = @"dsfdsf@gmail.com
sdsf@gg
sdfsdf_sdfsdf@gmail.com
sdfdsf.sdfds@gg.com
sdfsdf/sdfdsf/@gmail.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}