import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w.]+@[a-zA-Z]+[.]{1}com$";
final String string = "dsfdsf@gmail.com\n"
+ "sdsf@gg\n"
+ "sdfsdf_sdfsdf@gmail.com\n"
+ "sdfdsf.sdfds@gg.com\n"
+ "sdfsdf/sdfdsf/@gmail.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}