#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:\w*!){2}\w*$)[\w!]{5}$"
Local $sString = "abc!!" & @CRLF & _
"a!b!c" & @CRLF & _
"!!abc" & @CRLF & _
"a!!bc" & @CRLF & _
"f!o!o" & @CRLF & _
"" & @CRLF & _
"aaaa!" & @CRLF & _
"!aaaa" & @CRLF & _
"a!!!b" & @CRLF & _
"a!!!!" & @CRLF & _
"a!a!aa" & @CRLF & _
"!!!!!aaaaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")