import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:\\w*!){2}\\w*$)[\\w!]{5}$";
final String string = "abc!!\n"
+ "a!b!c\n"
+ "!!abc\n"
+ "a!!bc\n"
+ "f!o!o\n\n"
+ "aaaa!\n"
+ "!aaaa\n"
+ "a!!!b\n"
+ "a!!!!\n"
+ "a!a!aa\n"
+ "!!!!!aaaaa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}