re = /^(?=(?:\w*!){2}\w*$)[\w!]{5}$/m
str = 'abc!!
a!b!c
!!abc
a!!bc
f!o!o
aaaa!
!aaaa
a!!!b
a!!!!
a!a!aa
!!!!!aaaaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end