$re = '/^(?=(?:\w*!){2}\w*$)[\w!]{5}$/m';
$str = 'abc!!
a!b!c
!!abc
a!!bc
f!o!o
aaaa!
!aaaa
a!!!b
a!!!!
a!a!aa
!!!!!aaaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);