const regex = /^(?=(?:\w*!){2}\w*$)[\w!]{5}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:\\w*!){2}\\w*$)[\\w!]{5}$', 'gm')
const str = `abc!!
a!b!c
!!abc
a!!bc
f!o!o
aaaa!
!aaaa
a!!!b
a!!!!
a!a!aa
!!!!!aaaaa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}