using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#(<!--[TAG_START]-->)(.*)(<!--[TAG_END]-->)";
string substitution = @"f";
string input = @"<!--[TAG_START]-->a<!--[TAG_END]-->
<!--[TAG_START]-->b<!--[TAG_END]-->
<!--[TAG_START]-->c<!--[TAG_END]-->
<!--[TAG_START]-->d<!--[TAG_END]-->
<!--[TAG_START]-->e<!--[TAG_END]-->
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}