import Foundation
let pattern = ##"#(<!--[TAG_START]-->)(.*)(<!--[TAG_END]-->)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<!--[TAG_START]-->a<!--[TAG_END]-->
<!--[TAG_START]-->b<!--[TAG_END]-->
<!--[TAG_START]-->c<!--[TAG_END]-->
<!--[TAG_START]-->d<!--[TAG_END]-->
<!--[TAG_START]-->e<!--[TAG_END]-->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"f"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)