import re
regex = re.compile(r"#(<!--[TAG_START]-->)(.*)(<!--[TAG_END]-->)")
test_str = ("<!--[TAG_START]-->a<!--[TAG_END]-->\n"
"<!--[TAG_START]-->b<!--[TAG_END]-->\n"
"<!--[TAG_START]-->c<!--[TAG_END]-->\n"
"<!--[TAG_START]-->d<!--[TAG_END]-->\n"
"<!--[TAG_START]-->e<!--[TAG_END]-->\n")
subst = "f"
result = regex.sub(subst, test_str)
if result:
print(result)