const regex = /#(<!--[TAG_START]-->)(.*)(<!--[TAG_END]-->)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#(<!--[TAG_START]-->)(.*)(<!--[TAG_END]-->)', 'g')
const str = `<!--[TAG_START]-->a<!--[TAG_END]-->
<!--[TAG_START]-->b<!--[TAG_END]-->
<!--[TAG_START]-->c<!--[TAG_END]-->
<!--[TAG_START]-->d<!--[TAG_END]-->
<!--[TAG_START]-->e<!--[TAG_END]-->
`;
const subst = `f`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);