#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:[0-9][1-9]|[1-9][0-9])(?:\.(?:[0-9][1-9]|[1-9][0-9]))*)" & @CRLF & _
""
Local $sString = "00.11.01" & @CRLF & _
"11.00.11" & @CRLF & _
"11.11.00" & @CRLF & _
"11.01.11" & @CRLF & _
"01.01.01" & @CRLF & _
"11.00.11" & @CRLF & _
"99.90.99" & @CRLF & _
"0.11.11.01" & @CRLF & _
"01.12.23" & @CRLF & _
"01.11" & @CRLF & _
"01" & @CRLF & _
"00" & @CRLF & _
"01.01.01.01.01.01.00" & @CRLF & _
"01.01.01.01.01.01.01" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")