using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:[0-9][1-9]|[1-9][0-9])(?:\.(?:[0-9][1-9]|[1-9][0-9]))*)
";
string input = @"00.11.01
11.00.11
11.11.00
11.01.11
01.01.01
11.00.11
99.90.99
0.11.11.01
01.12.23
01.11
01
00
01.01.01.01.01.01.00
01.01.01.01.01.01.01
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}