package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:[0-9][1-9]|[1-9][0-9])(?:\.(?:[0-9][1-9]|[1-9][0-9]))*)
`)
var str = `00.11.01
11.00.11
11.11.00
11.01.11
01.01.01
11.00.11
99.90.99
0.11.11.01
01.12.23
01.11
01
00
01.01.01.01.01.01.00
01.01.01.01.01.01.01
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}