$re = '/^((?:[0-9][1-9]|[1-9][0-9])(?:\.(?:[0-9][1-9]|[1-9][0-9]))*)
/m';
$str = '00.11.01
11.00.11
11.11.00
11.01.11
01.01.01
11.00.11
99.90.99
0.11.11.01
01.12.23
01.11
01
00
01.01.01.01.01.01.00
01.01.01.01.01.01.01
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);