import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:[0-9][1-9]|[1-9][0-9])(?:\\.(?:[0-9][1-9]|[1-9][0-9]))*)\n";
final String string = "00.11.01\n"
+ "11.00.11\n"
+ "11.11.00\n"
+ "11.01.11\n"
+ "01.01.01\n"
+ "11.00.11\n"
+ "99.90.99\n"
+ "0.11.11.01\n"
+ "01.12.23\n"
+ "01.11\n"
+ "01\n"
+ "00\n"
+ "01.01.01.01.01.01.00\n"
+ "01.01.01.01.01.01.01\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}