#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m){%\h*block\h*content\h*%}\R((?:(?!{%\h*endblock\h*%}).*\R)*){%\h*endblock\h*%}"
Local $sString = "{% block content %}" & @CRLF & _
"Content of the page..." & @CRLF & _
"{% endblock %}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"{% block content %}" & @CRLF & _
"{{ a_tag }}" & @CRLF & _
"Content of the page..." & @CRLF & _
"{% endblock %}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")