import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{%\\h*block\\h*content\\h*%\\}\\R((?:(?!\\{%\\h*endblock\\h*%\\}).*\\R)*)\\{%\\h*endblock\\h*%\\}";
final String string = "{% block content %}\n"
+ "Content of the page...\n"
+ "{% endblock %}\n\n\n"
+ "{% block content %}\n"
+ "{{ a_tag }}\n"
+ "Content of the page...\n"
+ "{% endblock %}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}