const regex = new RegExp('{%\\h*block\\h*content\\h*%}\\R((?:(?!{%\\h*endblock\\h*%}).*\\R)*){%\\h*endblock\\h*%}', 'gm')
const str = `{% block content %}
Content of the page...
{% endblock %}
{% block content %}
{{ a_tag }}
Content of the page...
{% endblock %}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}