re = /{%\h*block\h*content\h*%}\R((?:(?!{%\h*endblock\h*%}).*\R)*){%\h*endblock\h*%}/m
str = '{% block content %}
Content of the page...
{% endblock %}
{% block content %}
{{ a_tag }}
Content of the page...
{% endblock %}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end