$re = '`{%\h*block\h*content\h*%}\R((?:(?!{%\h*endblock\h*%}).*\R)*){%\h*endblock\h*%}`m';
$str = '{% block content %}
Content of the page...
{% endblock %}
{% block content %}
{{ a_tag }}
Content of the page...
{% endblock %}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);