#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d{1,3}[A-I])?$"
Local $sString = "" & @CRLF & _
"123A" & @CRLF & _
"123b" & @CRLF & _
"123B" & @CRLF & _
"12Z" & @CRLF & _
"12A" & @CRLF & _
"A" & @CRLF & _
"10A" & @CRLF & _
"123B" & @CRLF & _
"33F" & @CRLF & _
"1A" & @CRLF & _
"1234A" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")