package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d{1,3}[A-I])?$`)
var str = `
123A
123b
123B
12Z
12A
A
10A
123B
33F
1A
1234A
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}