const regex = /^(?:\d{1,3}[A-I])?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{1,3}[A-I])?$', 'gm')
const str = `
123A
123b
123B
12Z
12A
A
10A
123B
33F
1A
1234A
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}