re = /^(?:\d{1,3}[A-I])?$/m
str = '
123A
123b
123B
12Z
12A
A
10A
123B
33F
1A
1234A
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end